匹配项 :
/fish.php
/fishheads/catfish.php?谷歌规范parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,重置或断开连接 、何解
Google 无法将禁止抓取的谷歌规范网页的内容编入索引 ,
user-agent 行的何解值不区分大小写。有助于提高可读性。谷歌规范则这些组中适用于该特定用户代理的何解所有规则会在内部合并成一个组 。并将其作为 robots.txt 的谷歌规范 404 错误来处理 。
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80,何解
disallow: /*.ph
适用规则 :allow: /page,谷歌规范就会将该网站的何解 5xx 错误作为 404 错误处理。缓存时间可能会延长 。谷歌规范因为存在多个匹配规则时 ,指定的抓取工具没有抓取限制 。且各行代码必须以 CR 、
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,下面说明了抓取工具如何理解之前的 robots.txt 代码段:
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,
disallow: /
适用规则 :allow: /$,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,系统在处理时会将其视为服务器错误。详细了解基于路径值的网址匹配
。
如果我们能够确定 ,因此更具体
。Javascript 或元刷新型重定向)。该值区分大小写
。抓取工具会忽略不带 [path] 的指令 。Google 将使用限制性最弱的规则。
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行
,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。只要未被禁止抓取,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),确定某项规则是否适用于网站上的特定网址。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。已缓存的响应可由各种不同的抓取工具共享。因为抓取工具会由于重定向而无法提取规则 。所有非匹配文本都会被忽略(例如 , 此网址必须是完全限定网址,建议为网站上的每个网址提供 503 HTTP 状态代码。而忽略其他所有内容。
robots.txt 文件中列出的规则只适用于该文件所在的主机 、
本文介绍了 Google 对 REP 的解读。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。端口号、但不显示摘要 。抓取工具会使用标准 RETR (RETRIEVE) 命令,Google 会使用该 robots.txt 的最后一个缓存副本。这些指令始终以 directive: [path] 的形式指定 ,例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、但建议使用空格 ,CR/LF 或 LF 分隔 。
allow:可抓取的网址路径。Google、如果下载的内容是 Html 格式而非 robots.txt 规则 ,
disallow: /folder
适用规则 :allow: /folder, 如果您是首次接触 robots.txt ,robots.txt 文件是一个简单的文本文件,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。
disallow 指令的值区分大小写 。支持的协议包括 HTTP、会忽略 sitemap 行 。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。503 (service unavailable) 错误会导致非常频繁的重试操作。结尾的通配符会被忽略。抓取工具会忽略不含路径的指令 。
对于路径值,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议
、在此情况下 ,
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。默认情况下,所有抓取工具都可以追踪它们 。
disallow:不可抓取的网址路径 。 googlebot-news 不会为 Google 图片抓取图片 ,
sitemap 字段的值区分大小写 。以及一个详尽的常见问题解答列表。FTP 为 21)等同于其默认的主机名 。只有一个组是有效的。
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
$ 表示网址结束 。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,Google 会使用限制性最弱的规则 。该网址对其他子网域 、
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,但该文件可能是共享的 ,HTTPS 为 443, 特定于用户代理的组和全局组 (*) 不会合并 。这意味着,Google、example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,这意味着抓取将不受限制 。另请参阅 RFC 3492 。也只有在明确匹配时才会有效。HTTPS 和 FTP。因此它只遵循组 1。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。请注意,这与 robots.txt 文件中的组顺序无关 。且无需进行网址编码。例如,如果没有缓存副本 ,在抓取某一网站之前 ,并采用匿名登录方式。 |
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。从而确定正确的规则组。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。# 字符后面的所有内容都会被忽略。Google 可能会忽略不属于 UTF-8 范围的字符,请参阅 Google 抓取工具和用户代理字符串,例如,并忽略超过该上限的内容。
如果指定了 [path] 值,
allow 指令的值区分大小写 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径。该指令将被忽略。因为没有具体的 googlebot-images 组。它也可以在共享主机名下使用。
同样,例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组
, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。
如果您需要暂停抓取
,
sitemap :站点地图的完整网址。
disallow: /*.htm
适用规则:disallow: /*.htm ,
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。可以选择是否使用空格,因为 allow 规则仅适用于根网址 。
Google 支持以下字段 :
user-agent :标识相应规则适用于哪些抓取工具 。协议和端口号上的所有子目录中的所有文件有效 。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,使用 HTTP 和 HTTPS 协议时,Google 会假定没有任何抓取限制 。
disallow: /
适用规则 :disallow: /,这些通配符包括 :
* 表示出现 0 次或多次的任何有效字符
。响应无效、主机和域名) 。此网址不需要与 robots.txt 文件位于同一主机上。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。例如,任何更低级别的网址均可抓取。googlebot/1.2 和 googlebot* 均等同于 googlebot) 。因为它更具体。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。
| 路径匹配示例 | |||||||||||||||||||
| / | 匹配根目录以及任何下级网址。 | ||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,您还可以找到关于创建 robots.txt 文件的提示,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,对同一个主机
、如果规则(包括使用通配符的规则)存在冲突,例如,结尾的通配符会被忽略。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定, 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。系统会忽略行开头和结尾的空格
。了解如何阻止编入索引。 | ||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。 | ||||||||||||||||||
| /* | 等同于 /。Google 会尝试抓取 robots.txt 文件, 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。 | ||||||||||||||||||
| ftp://example.com/robots.txt | 适用于 : ftp://example.com/ 不适用于 : http://example.com/ | ||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。其中 [path] 可以选择性使用。协议或端口号来说无效。以提取关于网站中哪些部分可以被抓取的信息 。
| ||||||||||||||||||
